Messj 发表于 2018-2-4 14:35:14

001:NUMBER BASE CONVERSION

本帖最后由 Messj 于 2018-6-8 23:33 编辑

总时间限制: 1000ms 内存限制: 65536kB

描述
Write a program to convert numbers in one base to numbers in a second base. There are 62 different digits:
{ 0-9,A-Z,a-z }
HINT: If you make a sequence of base conversions using the output of one conversion as the input to the next, when you get back to the original base, you should get the original number.

输入
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines will have a (decimal) input base followed by a (decimal) output base followed by a number expressed in the input base. Both the input base and the output base will be in the range from 2 to 62. That is (in decimal) A = 10, B = 11, ..., Z = 35, a = 36, b = 37, ..., z = 61 (0-9 have their usual meanings).

输出
The output of the program should consist of three lines of output for each base conversion performed. The first line should be the input base in decimal followed by a space then the input number (as given expressed in the input base). The second output line should be the output base followed by a space then the input number (as expressed in the output base). The third output line is blank.

样例输入
8
62 2 abcdefghiz
10 16 1234567890123456789012345678901234567890
16 35 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
35 23 333YMHOUE8JPLT7OX6K9FYCQ8A
23 49 946B9AA02MI37E3D3MMJ4G7BL2F05
49 61 1VbDkSIMJL3JjRgAdlUfcaWj
61 5 dl9MDSWqwHjDnToKcsWE1S
5 10 42104444441001414401221302402201233340311104212022133030

样例输出
62 abcdefghiz
2 11011100000100010111110010010110011111001001100011010010001

10 1234567890123456789012345678901234567890
16 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2

16 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
35 333YMHOUE8JPLT7OX6K9FYCQ8A

35 333YMHOUE8JPLT7OX6K9FYCQ8A
23 946B9AA02MI37E3D3MMJ4G7BL2F05

23 946B9AA02MI37E3D3MMJ4G7BL2F05
49 1VbDkSIMJL3JjRgAdlUfcaWj

49 1VbDkSIMJL3JjRgAdlUfcaWj
61 dl9MDSWqwHjDnToKcsWE1S

61 dl9MDSWqwHjDnToKcsWE1S
5 42104444441001414401221302402201233340311104212022133030

5 42104444441001414401221302402201233340311104212022133030
10 1234567890123456789012345678901234567890

Messj 发表于 2018-2-4 15:05:15

#include<cstdio>
#include<iostream>
#include<cstring>

const int maxn=1000;
using namespace std;

int n,m;
char str1,str2;
int t,A;

void solve(char *str1,char *str2,int n,int m)
{
        int len,i,k;
        len = strlen(str1);
        for(i=len;i>=0;i--)
        {
                t=str1-(str1<58?48:str1<91?55:61);    //ascii '0'-48 'A'-65 'a'-97
        }
        for(i=0;len;)
        {
                for(i=len;i>0;i--)
                {
                        t=t%m*n;
                        t/=m;
                }
                A=t%m;
                t/=m;
                while(len>0&&!t)
                {
                        len--;
                }
        }
        str2=NULL;
        for(i=0;i<k;i++)
        {
                str2 = A+(A<10?48:A<36?55:61);
        }
}
int main()
{
        int i,T;
        cin>>T;
        for(i=0;i<T;i++)
        {
                cin>>n>>m>>str1;
                solve(str1,str2,n,m);
                cout<<n<<" "<<str1<<endl;
                cout<<m<<" "<<str2<<endl;
                if(i!=T-1)
                        cout<<endl;
        }
}
页: [1]
查看完整版本: 001:NUMBER BASE CONVERSION