NYJYA 发表于 2019-2-6 22:14:52

请问为什么输入1或2或其他指定的字符串后不能得到预期的结果呢?谢谢了

题目描述
定义结构体,存储学生学号和三门课成绩及平均分,初始化成绩如下{{1,90,80,70},{2,85,75,95},{3,88,84,65}},输入学号,输出平均分,输入max,输出最高分id。

输入描述
输入学号或max

输出描述
输出平均分或最高分id

样例输入
//样例
1

//样例
max

//样例
4

样例输出
//样例
80

//样例
2

//样例
0
#include<stdio.h>
#include<string.h>
struct student
{
        int num;
        int g;
        int aver;
}stu={{1,90,80,70},{2,85,75,95},{3,88,84,65}};
int main()
{
        int i,j,max,t;
        char a,(*p);
        for(i=0;i<3;i++)
                stu.aver=0.0;
        for(i=0;i<3;i++)
                {
                        for(j=0;j<3;j++)               
                        stu.aver+=stu.g;
                        stu.aver=stu.aver/3.0;
                }
                        if(stu.aver>stu.aver)
                        {
                                max=stu.aver;t=1;
                        }
                        else
                        {
                                max=stu.aver;t=2;
                        }       
                        if(stu.aver>max)
                        {
                                max=stu.aver;t=3;
                        }
                        gets(a);
                        p=&a;
                        if(*p=="1")
                        printf("%d\n",stu.aver);
                        else if(*p=="2")
                        printf("%d\n",stu.aver);
                        else if(*p=="3")
                        printf("%d\n",stu.aver);
                        else if(*p=="max")
                        printf("%d\n",t);
                        else printf("0");               
                        return 0;
}

ba21 发表于 2019-2-7 15:20:14

先请原谅我爆出口。这狗屎一样的代码,代码不整洁,逻辑不清晰。
本来想在原来的基础上改改,看了10几分钟实在看不下去。

于是按题目写了如下代码(参考):
#include<stdio.h>
#include<string.h>

struct Score
{
        int chinese;
        int math;
        int english;
};

typedef struct Student
{
        int num;
    struct Score score;
    double aver;
} St;


int main()
{
        St stu = {{1,90,80,70}, {2,85,75,95}, {3,88,84,65}};
        int i, id;
        double max = 0;       
        char s={'\0'};

        for(i=0; i<3; i++)
        {
                stu.aver = (stu.score.chinese + stu.score.math + stu.score.english) / 3;

                if (stu.aver > max) // 此处便可获取最高分ID
                {
                        max = stu.aver;
                        id = stu.num;
                }
        }
       
        printf("请输入学号/max:");

        gets(s);

        if( strcmp(s,"1")==0 )
        {
                printf("%f\n", stu.aver);
        }
        else if( strcmp(s,"2")==0 )
        {
                printf("%f\n", stu.aver);
        }
        else if( strcmp(s,"3")==0 )
        {
                printf("%f\n", stu.aver);
        }
        else if( strcmp(s,"max")==0 )
        {
                printf("最高分ID是:%d\n", id);
        }
        else
        {
                printf("0");
        }

        return 0;
}
页: [1]
查看完整版本: 请问为什么输入1或2或其他指定的字符串后不能得到预期的结果呢?谢谢了