1个点未通过,麻烦大佬看看,有啥缺陷
题目:本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
如果密码合法,输出Your password is wan mei.;
如果密码太短,不论合法与否,都输出Your password is tai duan le.;
如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.
我只想到的一种缺陷:如果是>5的'.'的字符串改输出啥呢?
#include <iostream>
#include <cctype>
using namespace std;
#include <string>
int main(void)
{
int index;
string s1;
cin >> index;
int zimu=0,xiaoshudian=0,shuzi=0,qita=0;
for(int i=0;i<index;i++)
{
zimu=0;xiaoshudian=0;shuzi=0;qita=0;
cin >> s1;
if(s1.size()<6)
{
cout<<"Your password is tai duan le."<<endl;
}
else
{
for(int j=0;j<s1.size();j++)
{
if(s1=='.')
{
xiaoshudian++;
continue;
}
if(isalpha(s1))
{
zimu++;continue;
}
if(isdigit(s1))
{
shuzi++;continue;
}
else
{
qita++;
}
}
if(qita)
{
cout << "Your password is tai luan le."<<endl;
continue;
}
if(!zimu)
{
cout << "Your password needs zi mu."<<endl;
}
if(!shuzi)
{
cout <<"Your password needs shu zi."<<endl;
}
if(zimu && shuzi)
{
cout <<"Your password is wan mei."<<endl;
}
}
}
system("pause");
return 0;
}
所有的输入都保存起来,让所有的输出都在一起看看
#include <iostream>
#include <string>
#include <cctype>
int main()
{
int num;
std::cin >> num;
std::string *s = new std::string;
for(int i = 0; i < num; ++i) std::cin >> s;
for(int i = 0; i < num; ++i) {
if(s.size() < 6) {
std::cout << "Your password is tai duan le." << std::endl;
continue;
}
bool digit = false;
bool alpha = false;
bool invalid = false;
for(const auto j: s) {
if(isalpha(j)) alpha = true;
else if(isdigit(j)) digit = true;
else if(j != '.') {
invalid = true;
break;
}
}
if(invalid) std::cout << "Your password is tai luan le." << std::endl;
else if(alpha && !digit) std::cout << "Your password needs shu zi." << std::endl;
else if(!alpha && digit) std::cout << "Your password needs zi mu." << std::endl;
else std::cout << "Your password is wan mei." << std::endl;
}
delete[] s;
return 0;
}
页:
[1]