lsdsg 发表于 2021-11-14 16:56:26

编程题6

输入两个字符串(长度<100),从第一个字符串中删除第二个字符串中出现的所有字符。例如,输入“This is a example.”和“aeiou”,则删除之后的第一个字符串变成“Ths sxmpl.”



【输入形式】

输入2个字符串



【输出形式】

输出删除字符之后的字符串



【样例输入】

This is a example.

aeiou



【样例输出】

Ths sxmpl.

jackz007 发表于 2021-11-14 18:14:36

#include <stdio.h>

int main(void)
{
      char s1 , s2                                                ;
      int i , j , k                                                         ;
      gets(s1)                                                                ;
      fflush(stdin)                                                         ;
      gets(s2)                                                                ;
      for(i = 0 ; s2 ; i ++) {
                for(j = 0 ; s1 ;) {
                        if(s1 == s2) {
                              for(k = j + 1 ; s1 ; k ++) s1 = s1 ;
                              s1 = '\0'                                 ;
                        } else {
                              j ++                                          ;
                        }
                }
      }
      printf("%s\n" , s1)                                                   ;
}
      编译、运行实况:
D:\00.Excise\C>g++ -o x x.c

D:\00.Excise\C>x
This is a example.
aeiou
Ths sxmpl.

D:\00.Excise\C>
页: [1]
查看完整版本: 编程题6