这怎么改啊(多了两个空格输出)
本题要求实现一个函数,统计给定字符串中的大写字母、小写字母、空格、数字以及其它字符各有多少。函数接口定义:
void StringCount( char *s );
其中 char *s 是用户传入的字符串。函数StringCount须在一行内按照
大写字母个数 小写字母个数 空格个数 数字个数 其它字符个数
的格式输出。
裁判测试程序样例:
#include <stdio.h>
#define MAXS 15
void StringCount( char *s );
void ReadString( char *s ); /* 由裁判实现,略去不表 */
int main()
{
char s;
ReadString(s);
StringCount(s);
return 0;
}
void ReadString( char *s )
{
int i;
for( i=0;scanf("%c",s+i)!=EOF;i++)
{
if(*(s+i)=='#')
break;
}
}
/* Your function will be put here */
输入
输入字符以 # 字符结束(#字符不计入)
输出
根据题目输出
样例输入 Copy
aZ&*?
093 Az#
样例输出 Copy
2 2 1 3 4
提示
回车符也是字符
#include <stdio.h>
#define MAXS 15
void StringCount( char *s ) {
int digit=0,sma=0,big=0,blank=0,other=0;
while(*s!='\0') {
if(*s>='0'&&*s<='9')
digit++;
else if(*s>='a'&&*s<='z')
sma++;
else if(*s>='A'&&*s<='Z')
big++;
else if(*s==' ')
blank++;
else
other++;
s++;
}
printf("%d %d %d %d %d",big,sma,blank,digit,other);
}
void ReadString( char *s ); /* 由裁判实现,略去不表 */
int main() {
char s;
ReadString(s);
StringCount(s);
return 0;
}
void ReadString( char *s ) {
int i;
for( i=0; scanf("%c",s+i)!=EOF; i++) {
if(*(s+i)=='#')
break;
}
} #include <stdio.h>
#include <ctype.h>
int main()
{
char c;
int lower = 0, upper = 0, space = 0, digit = 0, other = 0;
while((c = getchar()) != '#'){
if(islower(c)) lower++;
else if(isupper(c)) upper++;
else if(c == ' ') space++;
else if(isdigit(c)) digit++;
else other++;
}
printf("\n");
printf("\n英文字母小写:%d\n英文字母大写:%d\n空格:%d\n数字:%d\n其它:%d", lower, upper, space, digit, other);
return 0;
} 傻眼貓咪 发表于 2021-12-9 18:58
改成函数怎么改呢 牵风 发表于 2021-12-9 20:29
改成函数怎么改呢
#include <stdio.h>
#include <ctype.h>
#include <string.h>
void res(char *str, int n){
int lower = 0, upper = 0, space = 0, digit = 0, other = 0;
char c;
for(size_t i = 0; i < n && str != '#'; i++){
c = str;
if(islower(c)) lower++;
else if(isupper(c)) upper++;
else if(c == ' ') space++;
else if(isdigit(c)) digit++;
else other++;
}
printf("\n英文字母小写:%d\n英文字母大写:%d\n空格:%d\n数字:%d\n其它:%d", lower, upper, space, digit, other);
}
int main()
{
char str;
fgets(str, 250, stdin);
res(str, strlen(str));
return 0;
}
页:
[1]