乔治爱啃脚趾 发表于 2023-10-27 19:12:11

java函数题

裁判测试程序样例中展示的是一段二维向量类TDVector的定义以及二维向量求和的Java代码,其中缺失了部分代码,请补充完整,以保证测试程序正常运行。

函数接口定义:
提示:需要补充的成员方法有:
1. 无参构造方法
2. 带参构造方法
3. getX
4. getY
5. setX
6. setY
7. add方法
裁判测试程序样例:
import java.util.Scanner;
class TDVector {
    private double x;
    private double y;
    public String toString() {
      return "("+this.x+","+this.y+")";
    }
   
    /** 你所提交的代码将被嵌在这里(替换此行) **/
   
}
public class Main {
    public static void main(String[] args) {
      TDVector a = new TDVector();/* 无参构造,向量的x和y默认为0 */
      Scanner sc = new Scanner(System.in);
      double x,y,z;
      x = sc.nextDouble();
      y = sc.nextDouble();
      z = sc.nextDouble();      
      TDVector b = new TDVector(x, y);/* 按照参数构造向量的x和y */
      TDVector c = new TDVector(b);/* 按照向量b构造向量 */
      a.setY(z);
      System.out.println(a);
      System.out.println(b);
      System.out.println(c);
      c.setX(z);
      a = b.add(c);
      System.out.println(a);
      System.out.println("b.x="+b.getX()+" b.y="+b.getY());
      sc.close();
    }
}
输入样例:
3.14 1.9 2.72
输出样例:
(0.0,2.72)
(3.14,1.9)
(3.14,1.9)
(5.86,3.8)
b.x=3.14 b.y=1.9

这个题目是什么意思啊,根本看不懂

isdkz 发表于 2023-10-27 19:12:21

这个题目要求你完成一个二维向量类TDVector的代码。你需要补充完整的代码以保证测试程序正常运行。

首先,你需要在TDVector类中添加无参构造方法和带参构造方法。无参构造方法用于创建一个默认的向量,其中x和y的值都为0。带参构造方法用于根据给定的参数创建一个具有指定x和y值的向量。

其次,你需要添加getX和getY方法,这两个方法分别用于获取向量的x和y值。

然后,你需要添加setX和setY方法,这两个方法分别用于设置向量的x和y值。

最后,你需要添加add方法,该方法接受一个TDVector对象作为参数,并返回一个新的TDVector对象,表示两个向量的和。

以下是完整的代码实现:

import java.util.Scanner;

class TDVector {
    private double x;
    private double y;

    public TDVector() {
      this.x = 0;
      this.y = 0;
    }

    public TDVector(double x, double y) {
      this.x = x;
      this.y = y;
    }

    public TDVector(TDVector vector) {
      this.x = vector.x;
      this.y = vector.y;
    }

    public double getX() {
      return this.x;
    }

    public double getY() {
      return this.y;
    }

    public void setX(double x) {
      this.x = x;
    }

    public void setY(double y) {
      this.y = y;
    }

    public TDVector add(TDVector vector) {
      double newX = this.x + vector.x;
      double newY = this.y + vector.y;
      return new TDVector(newX, newY);
    }

    public String toString() {
      return "(" + this.x + "," + this.y + ")";
    }
}

public class Main {
    public static void main(String[] args) {
      TDVector a = new TDVector();// 无参构造,向量的x和y默认为0
      Scanner sc = new Scanner(System.in);
      double x, y, z;
      x = sc.nextDouble();
      y = sc.nextDouble();
      z = sc.nextDouble();
      TDVector b = new TDVector(x, y);// 按照参数构造向量的x和y
      TDVector c = new TDVector(b);// 按照向量b构造向量
      a.setY(z);
      System.out.println(a);
      System.out.println(b);
      System.out.println(c);
      c.setX(z);
      a = b.add(c);
      System.out.println(a);
      System.out.println("b.x=" + b.getX() + " b.y=" + b.getY());
      sc.close();
    }
}


你可以将这段代码复制到你的IDE中进行编译和运行,然后输入3.14、1.9和2.72,即可得到与输出样例相同的结果。

陶远航 发表于 2023-10-27 19:12:33

这个题目要求你完成一个二维向量类TDVector的定义,并补充缺失的代码,以使得测试程序能够正常运行。具体需要实现的方法有:

1. 无参构造方法(默认将向量的x和y设置为0)
2. 带参构造方法(根据传入的参数设置向量的x和y)
3. getX方法(返回向量的x值)
4. getY方法(返回向量的y值)
5. setX方法(设置向量的x值)
6. setY方法(设置向量的y值)
7. add方法(将当前向量与另一个向量相加,并返回结果向量)

完成以上方法后,你可以在裁判测试程序中进行测试,通过输入一些数据,验证你实现的代码是否正确。
请注意,本回答来自GPT-4
如果问题已经解决,请设置最佳答案

Mike_python小 发表于 2023-10-27 19:13:35

函数接口定义:

java
class TDVector {
    private double x;
    private double y;

    // 无参构造方法
    public TDVector() {
      this.x = 0;
      this.y = 0;
    }

    // 带参构造方法
    public TDVector(double x, double y) {
      this.x = x;
      this.y = y;
    }

    // 拷贝构造方法
    public TDVector(TDVector vector) {
      this.x = vector.x;
      this.y = vector.y;
    }

    // 获取x的值
    public double getX() {
      return this.x;
    }

    // 获取y的值
    public double getY() {
      return this.y;
    }

    // 设置x的值
    public void setX(double x) {
      this.x = x;
    }

    // 设置y的值
    public void setY(double y) {
      this.y = y;
    }

    // 向量相加
    public TDVector add(TDVector other) {
      double sumX = this.x + other.x;
      double sumY = this.y + other.y;
      return new TDVector(sumX, sumY);
    }

    // 字符串表示形式
    public String toString() {
      return "(" + this.x + "," + this.y + ")";
    }
}


主程序部分:

java
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
      TDVector a = new TDVector();// 无参构造,向量的x和y默认为0
      Scanner sc = new Scanner(System.in);
      double x, y, z;
      x = sc.nextDouble();
      y = sc.nextDouble();
      z = sc.nextDouble();
      TDVector b = new TDVector(x, y);// 按照参数构造向量的x和y
      TDVector c = new TDVector(b);// 按照向量b构造向量
      a.setY(z);
      System.out.println(a);
      System.out.println(b);
      System.out.println(c);
      c.setX(z);
      a = b.add(c);
      System.out.println(a);
      System.out.println("b.x=" + b.getX() + " b.y=" + b.getY());
      sc.close();
    }
}


输入样例:

3.14 1.9 2.72


输出样例:

(0.0,2.72)
(3.14,1.9)
(3.14,1.9)
(5.86,3.8)
b.x=3.14 b.y=1.9


这个题目是关于二维向量类的定义和使用。在代码中,TDVector是一个包含x和y坐标的二维向量类。你需要完成该类的构造方法、获取和设置坐标的方法,以及向量相加的方法。然后在Main类中实例化对象并进行操作,最后输出结果。

球一个最佳答案谢谢啦!这对我非常重要!{:10_254:}{:10_254:}{:10_254:}
页: [1]
查看完整版本: java函数题