031:非常可乐
Description大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
Sample Input
7 4 3
4 1 3
0 0 0
Sample Output
NO
3 首先要深刻理解BFS,它不止用于地图,迷宫的问题。像这种求状态转移最快的步数或步骤的,就可以用BFS。这题也可以用广搜,以后求最短,最快,最少的问题(等权)都可以往广搜上面想想。。。理解每个”step“的含义,这里每一个step就是在正确的倒水路径上的每一次倒水,一共有6次倒水的方法,让每个“step”做这6个“动作”,然后一直这样往下”各个方向弥漫“,就一定会找到答案。
(注:对方向和步骤的理解不能太死板。要像理解面向对象一样。)
#include<cstdio>
#include<queue>
#define maxn 101
using namespace std;
struct N
{
int a,b,c;
int t;
};
queue<N> Q;
bool mark;
void AtoB(int &a,int sa,int &b,int sb)
{
if(sb-b>=a)
{
b+=a;
a=0;
}
else
{
a-=sb-b;
b=sb;
}
}
int BFS(int s,int n,int m)
{
int h=s/2;
while(!Q.empty())
{
N now=Q.front();
Q.pop();
int a,b,c;
a=now.a;
b=now.b;
c=now.c;
AtoB(a,s,b,n);
if(mark==false)
{
mark==true;
N tmp;
tmp.a=a;
tmp.b=b;
tmp.c=c;
tmp.t=now.t+1;
if(a==h&&b==h)
return tmp.t;
if(b==h&&c==h)
return tmp.t;
if(a==h&&c==h)
return tmp.t;
Q.push(tmp);
}
a=now.a;
b=now.b;
c=now.c;
AtoB(b,n,a,s);
if(mark==false)
{
mark==true;
N tmp;
tmp.a=a;
tmp.b=b;
tmp.c=c;
tmp.t=now.t+1;
if(a==h&&b==h)
return tmp.t;
if(b==h&&c==h)
return tmp.t;
if(a==h&&c==h)
return tmp.t;
Q.push(tmp);
}
a=now.a;
b=now.b;
c=now.c;
AtoB(a,s,c,m);
if(mark==false)
{
mark==true;
N tmp;
tmp.a=a;
tmp.b=b;
tmp.c=c;
tmp.t=now.t+1;
if(a==h&&b==h)
return tmp.t;
if(b==h&&c==h)
return tmp.t;
if(a==h&&c==h)
return tmp.t;
Q.push(tmp);
}
a=now.a;
b=now.b;
c=now.c;
AtoB(c,m,a,s);
if(mark==false)
{
mark==true;
N tmp;
tmp.a=a;
tmp.b=b;
tmp.c=c;
tmp.t=now.t+1;
if(a==h&&b==h)
return tmp.t;
if(b==h&&c==h)
return tmp.t;
if(a==h&&c==h)
return tmp.t;
Q.push(tmp);
}
a=now.a;
b=now.b;
c=now.c;
AtoB(b,n,c,m);
if(mark==false)
{
mark==true;
N tmp;
tmp.a=a;
tmp.b=b;
tmp.c=c;
tmp.t=now.t+1;
if(a==h&&b==h)
return tmp.t;
if(b==h&&c==h)
return tmp.t;
if(a==h&&c==h)
return tmp.t;
Q.push(tmp);
}
a=now.a;
b=now.b;
c=now.c;
AtoB(c,m,b,n);
if(mark==false)
{
mark==true;
N tmp;
tmp.a=a;
tmp.b=b;
tmp.c=c;
tmp.t=now.t+1;
if(a==h&&b==h)
return tmp.t;
if(b==h&&c==h)
return tmp.t;
if(a==h&&c==h)
return tmp.t;
Q.push(tmp);
}
}
return -1;
}
int main()
{
int s,n,m;
while(scanf("%d%d%d",&s,&n,&m)!=EOF)
{
if(s==0)
break;
if(s%2==1)
{
printf("NO\n");
continue;
}
for(int i=0;i<=s;i++)
for(int j=0;j<=n;j++)
for(int k=0;k<=m;k++)
mark=false;
N tmp;
tmp.a=s;
tmp.b=0;
tmp.c=0;
tmp.t=0;
while(!Q.empty())
Q.pop();
Q.push(tmp);
mark=true;
int rec=BFS(s,n,m);
if(rec==-1)
printf("NO\n");
else
printf("%d\n",rec);
}
return 0;
}
页:
[1]