鱼C论坛

 找回密码
 立即注册
查看: 3170|回复: 1

[技术交流] 031:非常可乐

[复制链接]
发表于 2018-2-17 14:11:33 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能^_^

您需要 登录 才可以下载或查看,没有账号?立即注册

x
Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input
7 4 3
4 1 3
0 0 0

Sample Output
NO
3

本帖被以下淘专辑推荐:

想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

 楼主| 发表于 2018-2-17 14:15:50 | 显示全部楼层
首先要深刻理解BFS,它不止用于地图,迷宫的问题。像这种求状态转移最快的步数或步骤的,就可以用BFS。这题也可以用广搜,以后求最短,最快,最少的问题(等权)都可以往广搜上面想想。。。理解每个”step“的含义,这里每一个step就是在正确的倒水路径上的每一次倒水,一共有6次倒水的方法,让每个“step”做这6个“动作”,然后一直这样往下”各个方向弥漫“,就一定会找到答案。
(注:对方向和步骤的理解不能太死板。要像理解面向对象一样。)
#include<cstdio>
#include<queue>
#define maxn 101

using namespace std;

struct N
{
        int a,b,c;
        int t;
};
queue<N> Q;
bool mark[maxn][maxn][maxn];
void AtoB(int &a,int sa,int &b,int sb)
{
        if(sb-b>=a)
        {
                b+=a;
                a=0;
        }
        else
        {
                a-=sb-b;
                b=sb;
        }
}
int BFS(int s,int n,int m)
{
        int h=s/2;
        while(!Q.empty())
        {
                N now=Q.front();
                Q.pop();
                int a,b,c;
                a=now.a;
                b=now.b;
                c=now.c;
                AtoB(a,s,b,n);
                if(mark[a][b][c]==false)
                {
                        mark[a][b][c]==true;
                        N tmp;
                        tmp.a=a;
                        tmp.b=b;
                        tmp.c=c;
                        tmp.t=now.t+1;
                        if(a==h&&b==h)
                                return tmp.t;
                        if(b==h&&c==h)
                                return tmp.t;
                        if(a==h&&c==h)
                                return tmp.t;
                        Q.push(tmp);
                }
                a=now.a;
                b=now.b;
                c=now.c;
                AtoB(b,n,a,s);
                if(mark[a][b][c]==false)
                {
                        mark[a][b][c]==true;
                        N tmp;
                        tmp.a=a;
                        tmp.b=b;
                        tmp.c=c;
                        tmp.t=now.t+1;
                        if(a==h&&b==h)
                                return tmp.t;
                        if(b==h&&c==h)
                                return tmp.t;
                        if(a==h&&c==h)
                                return tmp.t;
                        Q.push(tmp);
                }
                a=now.a;
                b=now.b;
                c=now.c;
                AtoB(a,s,c,m);
                if(mark[a][b][c]==false)
                {
                        mark[a][b][c]==true;
                        N tmp;
                        tmp.a=a;
                        tmp.b=b;
                        tmp.c=c;
                        tmp.t=now.t+1;
                        if(a==h&&b==h)
                                return tmp.t;
                        if(b==h&&c==h)
                                return tmp.t;
                        if(a==h&&c==h)
                                return tmp.t;
                        Q.push(tmp);
                }
                a=now.a;
                b=now.b;
                c=now.c;
                AtoB(c,m,a,s);
                if(mark[a][b][c]==false)
                {
                        mark[a][b][c]==true;
                        N tmp;
                        tmp.a=a;
                        tmp.b=b;
                        tmp.c=c;
                        tmp.t=now.t+1;
                        if(a==h&&b==h)
                                return tmp.t;
                        if(b==h&&c==h)
                                return tmp.t;
                        if(a==h&&c==h)
                                return tmp.t;
                        Q.push(tmp);
                }
                a=now.a;
                b=now.b;
                c=now.c;
                AtoB(b,n,c,m);
                if(mark[a][b][c]==false)
                {
                        mark[a][b][c]==true;
                        N tmp;
                        tmp.a=a;
                        tmp.b=b;
                        tmp.c=c;
                        tmp.t=now.t+1;
                        if(a==h&&b==h)
                                return tmp.t;
                        if(b==h&&c==h)
                                return tmp.t;
                        if(a==h&&c==h)
                                return tmp.t;
                        Q.push(tmp);
                }
                a=now.a;
                b=now.b;
                c=now.c;
                AtoB(c,m,b,n);
                if(mark[a][b][c]==false)
                {
                        mark[a][b][c]==true;
                        N tmp;
                        tmp.a=a;
                        tmp.b=b;
                        tmp.c=c;
                        tmp.t=now.t+1;
                        if(a==h&&b==h)
                                return tmp.t;
                        if(b==h&&c==h)
                                return tmp.t;
                        if(a==h&&c==h)
                                return tmp.t;
                        Q.push(tmp);
                }
        }
        return -1;
}
int main()
{
        int s,n,m;
        while(scanf("%d%d%d",&s,&n,&m)!=EOF)
        {
                if(s==0)
                        break;
                if(s%2==1)
                {
                        printf("NO\n");
                        continue;
                }
                for(int i=0;i<=s;i++)
                        for(int j=0;j<=n;j++)
                                for(int k=0;k<=m;k++)
                                        mark[i][j][k]=false;
                N tmp;
                tmp.a=s;
                tmp.b=0;
                tmp.c=0;
                tmp.t=0;
                while(!Q.empty())
                        Q.pop();
                Q.push(tmp);
                mark[s][0][0]=true;
                int rec=BFS(s,n,m);
                if(rec==-1)
                        printf("NO\n");
                else
                        printf("%d\n",rec);
        }
        return 0;
}
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1 | 粤公网安备 44051102000585号)

GMT+8, 2024-11-6 07:25

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表