NYJYA 发表于 2019-1-29 21:52:10

该题这样写代码对吗?

题目描述
打印数字正方形

输入描述
输入一个整数n,1<=n<=31

输出描述
输出数字正方形。
注意,每个数字占4个字符,右对齐,不全则补足空格;


样例输入
10

样例输出
   1   2   3   4   5   6   7   8   910
11121314151617181920
21222324252627282930
31323334353637383940
41424344454647484950
51525354555657585960
61626364656667686970
71727374757677787980
81828384858687888990
919293949596979899 100
#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
        int n,i,j,k,a;
        for(i=0;i<10;i++)
        {
                for(j=0,k=1;k<=10,j<10;j++,k++)
                a=i*10+k;
        }
       
        cin >> n;
        for(i=0;i<n;i++)
        {
                for(j=0;j<n;j++)
                cout << setw(4) << a;
                cout << endl;
        }
        return 0;
}

Croper 发表于 2019-1-29 23:15:55

本帖最后由 Croper 于 2019-1-29 23:18 编辑

肯定不对啊,二维数组a的长宽只有10,你n=11的时候已经越界了

Croper 发表于 2019-1-29 23:35:12

#include <iostream>
#include <iomanip>
using namespace std;
int main()
{
        int n, k = 0;
        cin >> n;
        for (int i = 0; i < n; ++i)
        {
                cout << endl;
                for (int j = 0; j < n; ++j)
                        cout << setw(4) << ++k;
        }

        cout << endl;
        system("pause");
}
页: [1]
查看完整版本: 该题这样写代码对吗?