马上注册,结交更多好友,享用更多功能^_^
您需要 登录 才可以下载或查看,没有账号?立即注册
x
题目描述
打印数字正方形
输入描述
输入一个整数n,1<=n<=31
输出描述
输出数字正方形。
注意,每个数字占4个字符,右对齐,不全则补足空格;
样例输入
10
样例输出
1 2 3 4 5 6 7 8 9 10
11 12 13 14 15 16 17 18 19 20
21 22 23 24 25 26 27 28 29 30
31 32 33 34 35 36 37 38 39 40
41 42 43 44 45 46 47 48 49 50
51 52 53 54 55 56 57 58 59 60
61 62 63 64 65 66 67 68 69 70
71 72 73 74 75 76 77 78 79 80
81 82 83 84 85 86 87 88 89 90
91 92 93 94 95 96 97 98 99 100#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
int n,i,j,k,a[10][10];
for(i=0;i<10;i++)
{
for(j=0,k=1;k<=10,j<10;j++,k++)
a[i][j]=i*10+k;
}
cin >> n;
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
cout << setw(4) << a[i][j];
cout << endl;
}
return 0;
}
#include <iostream>
#include <iomanip>
using namespace std;
int main()
{
int n, k = 0;
cin >> n;
for (int i = 0; i < n; ++i)
{
cout << endl;
for (int j = 0; j < n; ++j)
cout << setw(4) << ++k;
}
cout << endl;
system("pause");
}
|