新手求助
为什么第二个数据无法输入??Problem Description
统计每个元音字母在字符串中出现的次数。
Input
输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串。
Output
对于每个测试实例输出5行,格式如下:
a:num1
e:num2
i:num3
o:num4
u:num5
多个测试实例之间由一个空行隔开,请特别注意:最后一块输出后面没有空行
Sample Input
2
aeiou
my name is ignatius
Sample Output
a:1
e:1
i:1
o:1
u:1
a:2
e:1
i:3
o:0
u:1
我的代码如下
#include<stdio.h>
#include<string.h>
int main()
{ char b;
int n=0,f,j;
int a,e,i,o,u;
while(scanf("%d",&n)!=EOF);
{
getchar();
for(int f=0;f<n;f++)
{ gets(b);
a=0, e=0, i=0, o=0, u=0;
for(int j=0;j<strlen(b);j++)
{
if(b=='a'||b=='A')
a++;
else if(b=='e'||b=='E')
e++;
else if(b=='i'||b=='I')
i++;
else if(b=='o'||b=='O')
o++;
else if(b=='u'||b=='U')
u++;
}
}
if(f==n-1)
{printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n",a,e,i,o,u);}
else
{printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n\n",a,e,i,o,u);}
}
return 0;
} #include <stdio.h>
#include <memory.h>
#include <ctype.h>
int main(void) {
size_t n; scanf("%lu\n", &n);
char strings;
for(size_t i = 0; i < n; ++i) fgets(strings, 101, stdin);
size_t counts; memset(counts, 0, sizeof(counts));
for(size_t i = 0; i < n; ++i) {
for(size_t j = 0; strings; ++j) {
++counts)];
}
}
const char *new_line = "";
char vowels[] = {'a', 'e', 'i', 'o', 'u', 0};
for(size_t i = 0; i < n; ++i) {
printf("%s", new_line); new_line = "\n";
for(size_t j = 0; vowels; ++j)
printf("%c:%lu\n", vowels, counts[(size_t)vowels]);
}
return 0;
}
本帖最后由 人造人 于 2021-10-3 11:59 编辑
我感觉题目的意思是要你把所有的输入先保存起来,然后计算,然后输出
感觉不是
接收一行输入,计算,输出
然后再接收一行输入,计算,输出
然后再接收一行输入,计算,输出
。。。
#include <stdio.h>
#include <memory.h>
int main(void) {
size_t n; scanf("%lu\n", &n);
char strings;
for(size_t i = 0; i < n; ++i) fgets(strings, 101, stdin);
size_t counts; memset(counts, 0, sizeof(counts));
for(size_t i = 0; i < n; ++i) {
for(size_t j = 0; strings; ++j) {
++counts[(size_t)strings];
}
}
const char *new_line = "";
for(size_t i = 0; i < n; ++i) {
printf("%s", new_line); new_line = "\n";
printf("%c:%lu\n", 'a', counts['a']);
printf("%c:%lu\n", 'e', counts['e']);
printf("%c:%lu\n", 'i', counts['i']);
printf("%c:%lu\n", 'o', counts['o']);
printf("%c:%lu\n", 'u', counts['u']);
}
return 0;
}
页:
[1]