|
10鱼币
为什么第二个数据无法输入??
Problem Description
统计每个元音字母在字符串中出现的次数。
Input
输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串。
Output
对于每个测试实例输出5行,格式如下:
a:num1
e:num2
i:num3
o:num4
u:num5
多个测试实例之间由一个空行隔开,请特别注意:最后一块输出后面没有空行
Sample Input
2
aeiou
my name is ignatius
Sample Output
a:1
e:1
i:1
o:1
u:1
a:2
e:1
i:3
o:0
u:1
我的代码如下#include<stdio.h>
#include<string.h>
int main()
{ char b[101];
int n=0,f,j;
int a,e,i,o,u;
while(scanf("%d",&n)!=EOF);
{
getchar();
for(int f=0;f<n;f++)
{ gets(b);
a=0, e=0, i=0, o=0, u=0;
for(int j=0;j<strlen(b);j++)
{
if(b[j]=='a'||b[j]=='A')
a++;
else if(b[j]=='e'||b[j]=='E')
e++;
else if(b[j]=='i'||b[j]=='I')
i++;
else if(b[j]=='o'||b[j]=='O')
o++;
else if(b[j]=='u'||b[j]=='U')
u++;
}
}
if(f==n-1)
{printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n",a,e,i,o,u);}
else
{printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n\n",a,e,i,o,u);}
}
return 0;
}
#include <stdio.h>
#include <memory.h>
#include <ctype.h>
int main(void) {
size_t n; scanf("%lu\n", &n);
char strings[n][101];
for(size_t i = 0; i < n; ++i) fgets(strings[i], 101, stdin);
size_t counts[n][256]; memset(counts, 0, sizeof(counts));
for(size_t i = 0; i < n; ++i) {
for(size_t j = 0; strings[i][j]; ++j) {
++counts[i][tolower(strings[i][j])];
}
}
const char *new_line = "";
char vowels[] = {'a', 'e', 'i', 'o', 'u', 0};
for(size_t i = 0; i < n; ++i) {
printf("%s", new_line); new_line = "\n";
for(size_t j = 0; vowels[j]; ++j)
printf("%c:%lu\n", vowels[j], counts[i][(size_t)vowels[j]]);
}
return 0;
}
|
|