鱼C论坛

 找回密码
 立即注册
查看: 2826|回复: 2

[已解决]新手求助

[复制链接]
发表于 2021-10-3 11:09:46 | 显示全部楼层 |阅读模式
10鱼币
为什么第二个数据无法输入??

Problem Description
统计每个元音字母在字符串中出现的次数。

Input
输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串。

Output
对于每个测试实例输出5行,格式如下:
a:num1
e:num2
i:num3
o:num4
u:num5
多个测试实例之间由一个空行隔开,请特别注意:最后一块输出后面没有空行

Sample Input
2
aeiou
my name is ignatius

Sample Output
a:1
e:1
i:1
o:1
u:1

a:2
e:1
i:3
o:0
u:1

我的代码如下
#include<stdio.h>
#include<string.h>

int main()
{   char b[101];
    int n=0,f,j;
    int a,e,i,o,u;
    
        while(scanf("%d",&n)!=EOF);
        {
                getchar();
                for(int f=0;f<n;f++)
            {   gets(b);
                    a=0, e=0, i=0, o=0, u=0;
                    for(int j=0;j<strlen(b);j++)
                    {
                            if(b[j]=='a'||b[j]=='A')
                            a++;
                            else if(b[j]=='e'||b[j]=='E')
                            e++;
                            else if(b[j]=='i'||b[j]=='I')
                            i++;
                            else if(b[j]=='o'||b[j]=='O')
                            o++;
                            else if(b[j]=='u'||b[j]=='U')
                            u++;
                        }
            }
            if(f==n-1)
            {printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n",a,e,i,o,u);}
            else
            {printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n\n",a,e,i,o,u);}
}

return 0;
} 
最佳答案
2021-10-3 11:09:47
#include <stdio.h>
#include <memory.h>
#include <ctype.h>

int main(void) {
    size_t n; scanf("%lu\n", &n);
    char strings[n][101];
    for(size_t i = 0; i < n; ++i) fgets(strings[i], 101, stdin);
    size_t counts[n][256]; memset(counts, 0, sizeof(counts));
    for(size_t i = 0; i < n; ++i) {
        for(size_t j = 0; strings[i][j]; ++j) {
            ++counts[i][tolower(strings[i][j])];
        }
    }
    const char *new_line = "";
    char vowels[] = {'a', 'e', 'i', 'o', 'u', 0};
    for(size_t i = 0; i < n; ++i) {
        printf("%s", new_line); new_line = "\n";
        for(size_t j = 0; vowels[j]; ++j)
            printf("%c:%lu\n", vowels[j], counts[i][(size_t)vowels[j]]);
    }
    return 0;
}
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 2021-10-3 11:09:47 | 显示全部楼层    本楼为最佳答案   
#include <stdio.h>
#include <memory.h>
#include <ctype.h>

int main(void) {
    size_t n; scanf("%lu\n", &n);
    char strings[n][101];
    for(size_t i = 0; i < n; ++i) fgets(strings[i], 101, stdin);
    size_t counts[n][256]; memset(counts, 0, sizeof(counts));
    for(size_t i = 0; i < n; ++i) {
        for(size_t j = 0; strings[i][j]; ++j) {
            ++counts[i][tolower(strings[i][j])];
        }
    }
    const char *new_line = "";
    char vowels[] = {'a', 'e', 'i', 'o', 'u', 0};
    for(size_t i = 0; i < n; ++i) {
        printf("%s", new_line); new_line = "\n";
        for(size_t j = 0; vowels[j]; ++j)
            printf("%c:%lu\n", vowels[j], counts[i][(size_t)vowels[j]]);
    }
    return 0;
}
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 2021-10-3 11:52:28 | 显示全部楼层
本帖最后由 人造人 于 2021-10-3 11:59 编辑

我感觉题目的意思是要你把所有的输入先保存起来,然后计算,然后输出
感觉不是
接收一行输入,计算,输出
然后再接收一行输入,计算,输出
然后再接收一行输入,计算,输出
。。。
#include <stdio.h>
#include <memory.h>

int main(void) {
    size_t n; scanf("%lu\n", &n);
    char strings[n][101];
    for(size_t i = 0; i < n; ++i) fgets(strings[i], 101, stdin);
    size_t counts[n][256]; memset(counts, 0, sizeof(counts));
    for(size_t i = 0; i < n; ++i) {
        for(size_t j = 0; strings[i][j]; ++j) {
            ++counts[i][(size_t)strings[i][j]];
        }
    }
    const char *new_line = "";
    for(size_t i = 0; i < n; ++i) {
        printf("%s", new_line); new_line = "\n";
        printf("%c:%lu\n", 'a', counts[i]['a']);
        printf("%c:%lu\n", 'e', counts[i]['e']);
        printf("%c:%lu\n", 'i', counts[i]['i']);
        printf("%c:%lu\n", 'o', counts[i]['o']);
        printf("%c:%lu\n", 'u', counts[i]['u']);
    }
    return 0;
}
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1 | 粤公网安备 44051102000585号)

GMT+8, 2025-1-2 00:49

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表