C 语言
题目:某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。
输入格式:
输入在第一行给出正整数 N,取值在(0,10 的5次方]随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。
输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct{
char name;
int year;
int month;
int day;
}people;
int compare(const void *a,const void *b){
people A=*(people *)a;
people B=*(people *)b;
if(A.year!=B.year) return B.year>=A.year;
else if(A.month!=B.month) return B.month>=A.month;
else return B.day>=A.day;
}
int main(void){
int n,i,k=0; //cot统计符合条件的人数
scanf("%d",&n);
people people;
int year,month,day;
char name; //临时存储名字
for(i=0;i<n;i++){
scanf("%s %d/%d/%d",name,&year,&month,&day);
getchar();
//用于判断是否符合出生年月日条件,符合则将它放进people结构体中
if(((year<2014) || (year==2014 && month<9) || (year==2014 && month==9 &&day<=6))
&&((year>1814)||(year==1814 && month>9)||(year==1814 && month==9 && day>=6))){
strcpy(people.name,name); //k顺便统计符合年龄条件的人数
people.year=year;
people.month=month;
people.day=day;
}
}
qsort(people,k,sizeof(people),compare); //将符合年龄条件的人排序
for(i=0;i<k;i++){
printf("%s\n",people.name);
}
return 0;
}
我这里打印出来的符合条件的人并没有排序,compare函数是出现在哪里了呢?请教大佬!!! 本帖最后由 jhq999 于 2022-5-5 08:52 编辑
结构体名居然和结构体实例重名
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef struct{
char name;
int year;
int month;
int day;
}People;///////////////////////////////////////////////////////////////
int compare(const void *a,const void *b){
People A=*(People *)a;
People B=*(People *)b;
if(A.year!=B.year) return B.year-A.year; ///////////////////////////////////////
else if(A.month!=B.month) return B.month-A.month;///////////////////////////////////
else return B.day-A.day;///////////////////////////////////////////////
}
int main(void){
int n,i,k=0; //cot统计符合条件的人数
scanf("%d",&n);
People *people=new People;
int year,month,day;
char name; //临时存储名字
for(i=0;i<n;i++){
scanf("%s %d/%d/%d",name,&year,&month,&day);
getchar();
//用于判断是否符合出生年月日条件,符合则将它放进people结构体中
if(((year<2014) || (year==2014 && month<9) || (year==2014 && month==9 &&day<=6))
&&((year>1814)||(year==1814 && month>9)||(year==1814 && month==9 && day>=6))){
strcpy(people.name,name); //k顺便统计符合年龄条件的人数
people.year=year;//////////////////////////////////////////////////////
people.month=month;////////////////////////////////////////////////////////////
people.day=day;///////////////////////////////////////////////////////////
}
}
qsort(people,k,sizeof(People),compare); //将符合年龄条件的人排序 //////////////////////////////////////////////////////////////
for(i=0;i<k;i++){
printf("%s\n",people.name);
}
delete[] people;
return 0;
}
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
John
Steve
Tom jhq999 发表于 2022-5-5 08:47
结构体名居然和结构体实例重名
感谢感谢,当初小甲鱼老师讲过结构体变量名可以和结构体名一样,所以不想想那么多名字就直接用了{:10_266:}
页:
[1]