鱼C论坛

 找回密码
 立即注册
查看: 1922|回复: 1

[技术交流] 001:NUMBER BASE CONVERSION

[复制链接]
发表于 2018-2-4 14:35:14 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能^_^

您需要 登录 才可以下载或查看,没有账号?立即注册

x
本帖最后由 Messj 于 2018-6-8 23:33 编辑

总时间限制: 1000ms 内存限制: 65536kB

描述
Write a program to convert numbers in one base to numbers in a second base. There are 62 different digits:
{ 0-9,A-Z,a-z }
HINT: If you make a sequence of base conversions using the output of one conversion as the input to the next, when you get back to the original base, you should get the original number.

输入
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines will have a (decimal) input base followed by a (decimal) output base followed by a number expressed in the input base. Both the input base and the output base will be in the range from 2 to 62. That is (in decimal) A = 10, B = 11, ..., Z = 35, a = 36, b = 37, ..., z = 61 (0-9 have their usual meanings).

输出
The output of the program should consist of three lines of output for each base conversion performed. The first line should be the input base in decimal followed by a space then the input number (as given expressed in the input base). The second output line should be the output base followed by a space then the input number (as expressed in the output base). The third output line is blank.

样例输入
8
62 2 abcdefghiz
10 16 1234567890123456789012345678901234567890
16 35 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
35 23 333YMHOUE8JPLT7OX6K9FYCQ8A
23 49 946B9AA02MI37E3D3MMJ4G7BL2F05
49 61 1VbDkSIMJL3JjRgAdlUfcaWj
61 5 dl9MDSWqwHjDnToKcsWE1S
5 10 42104444441001414401221302402201233340311104212022133030

样例输出
62 abcdefghiz
2 11011100000100010111110010010110011111001001100011010010001

10 1234567890123456789012345678901234567890
16 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2

16 3A0C92075C0DBF3B8ACBC5F96CE3F0AD2
35 333YMHOUE8JPLT7OX6K9FYCQ8A

35 333YMHOUE8JPLT7OX6K9FYCQ8A
23 946B9AA02MI37E3D3MMJ4G7BL2F05

23 946B9AA02MI37E3D3MMJ4G7BL2F05
49 1VbDkSIMJL3JjRgAdlUfcaWj

49 1VbDkSIMJL3JjRgAdlUfcaWj
61 dl9MDSWqwHjDnToKcsWE1S

61 dl9MDSWqwHjDnToKcsWE1S
5 42104444441001414401221302402201233340311104212022133030

5 42104444441001414401221302402201233340311104212022133030
10 1234567890123456789012345678901234567890

本帖被以下淘专辑推荐:

想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

 楼主| 发表于 2018-2-4 15:05:15 | 显示全部楼层
#include<cstdio>
#include<iostream>
#include<cstring>

const int maxn=1000;
using namespace std;

int n,m;
char str1[maxn],str2[maxn];
int t[maxn],A[maxn];

void solve(char *str1,char *str2,int n,int m)
{
        int len,i,k;
        len = strlen(str1);
        for(i=len;i>=0;i--)
        {
                t[len-1-i]=str1[i]-(str1[i]<58?48:str1[i]<91?55:61);    //ascii '0'-48 'A'-65 'a'-97
        }
        for(i=0;len;)
        {
                for(i=len;i>0;i--)
                {
                        t[i-1]=t[i]%m*n;
                        t[i]/=m;
                }
                A[k++]=t[0]%m;
                t[0]/=m;
                while(len>0&&!t[len-1])
                {
                        len--;
                }
        }
        str2[k]=NULL;
        for(i=0;i<k;i++)
        {
                str2[k-1-i] = A[i]+(A[i]<10?48:A[i]<36?55:61);
        }
}
int main()
{
        int i,T;
        cin>>T;
        for(i=0;i<T;i++)
        {
                cin>>n>>m>>str1;
                solve(str1,str2,n,m);
                cout<<n<<" "<<str1<<endl;
                cout<<m<<" "<<str2<<endl;
                if(i!=T-1)
                        cout<<endl;
        }
}
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1 | 粤公网安备 44051102000585号)

GMT+8, 2024-10-1 12:19

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表