鱼C论坛

 找回密码
 立即注册
查看: 1010|回复: 3

[已解决]字符逆序

[复制链接]
发表于 2020-12-22 11:15:25 From FishC Mobile | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能^_^

您需要 登录 才可以下载或查看,没有账号?立即注册

x
输入一个字符串,对该字符串进行逆序,输出逆序后的字符串。
输入格式:
输入在一行中给出一个不超过80个字符长度的、以回车结束的非空字符串。
输出格式:
在一行中输出逆序后的字符串。
输入样例:
Hello World!
输出样例:
!dlroW olleH
最佳答案
2020-12-22 11:32:06
本帖最后由 jackz007 于 2020-12-22 11:33 编辑
#include <stdio.h>

int main(void)
{
        char c , s[80]                                                             ;
        int i , m                                                                  ;
        for(m = 0 ; m < 80 && (c = getchar()) != '\n' ; s[m ++] = c , s[m] = '\0') ;
        for(i = 0 ; i < m / 2 ; i ++) {
                c = s[i]                                                           ;
                s[i] = s[m - 1 - i]                                                ;
                s[m - 1 - i] = c                                                   ; 
        }              
        printf("%s\n" , s)                                                         ;
}
        编译、运行实况
D:\0002.Exercise\C>g++ -o x x.c

D:\0002.Exercise\C>x
hello , world !
! dlrow , olleh

D:\0002.Exercise\C>
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 2020-12-22 11:32:06 | 显示全部楼层    本楼为最佳答案   
本帖最后由 jackz007 于 2020-12-22 11:33 编辑
#include <stdio.h>

int main(void)
{
        char c , s[80]                                                             ;
        int i , m                                                                  ;
        for(m = 0 ; m < 80 && (c = getchar()) != '\n' ; s[m ++] = c , s[m] = '\0') ;
        for(i = 0 ; i < m / 2 ; i ++) {
                c = s[i]                                                           ;
                s[i] = s[m - 1 - i]                                                ;
                s[m - 1 - i] = c                                                   ; 
        }              
        printf("%s\n" , s)                                                         ;
}
        编译、运行实况
D:\0002.Exercise\C>g++ -o x x.c

D:\0002.Exercise\C>x
hello , world !
! dlrow , olleh

D:\0002.Exercise\C>
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

发表于 2020-12-22 11:49:28 | 显示全部楼层
int main()
{
        printf("cout string:");
        char str[80],temp;
        gets(str);
        int num = strlen(str);
        for (int i = 0; i < num/2 ; i++)
        {
                temp = str[i];
                str[i] = str[num - i - 1];
                str[num - i - 1] = temp;
        }
        puts(str);
        return 0;
}
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

发表于 2020-12-22 11:58:02 | 显示全部楼层
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
    char a[80];
    int i,n;
    gets(a);
    i=strlen(a);
    for(i-1; i>0; i--)
    {
        putchar(a[i-1]);
    }
}
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1 | 粤公网安备 44051102000585号)

GMT+8, 2025-1-12 10:00

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表