鱼C论坛

 找回密码
 立即注册
查看: 1816|回复: 0

[技术交流] Hello, world!

[复制链接]
发表于 2020-12-28 19:33:38 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能^_^

您需要 登录 才可以下载或查看,没有账号?立即注册

x
This is the first problem for test. Since all we know the ASCII code, your job is simple: Input numbers and output corresponding messages.
输入
The input will contain a list of positive integers separated by whitespaces(spaces, newlines, TABs). Please process to the end of file (EOF). The integers will be no less than 32.
输出
Output the corresponding message. Note there is NOT a newline character in the end of output.
样例输入
72 101 108 108 111 44
32 119 111 114 108 100 33
样例输出
Hello, world!
#include <stdio.h>
main()
{
        int a[20];
        int n;
        int m;
        int s=0;
        int b;
        printf("请输入你想输入的字符个数");
        scanf("%d",&n);
        printf("请输入你想输入的数字,请不要超过20个");
        for( b=0;b<n;b++)
        {
                scanf("%d",&m);
                a[s]=m;
                s++;        
        }
        
        for(b=0;b<n;b++)
        { 
                printf("%c",a[b]);
                
        }
        
 } 
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1 | 粤公网安备 44051102000585号)

GMT+8, 2025-1-12 06:51

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表