鱼C论坛

 找回密码
 立即注册
查看: 124|回复: 1

[已解决]银行业务队列简单模拟

[复制链接]
发表于 2024-11-1 17:45:01 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能^_^

您需要 登录 才可以下载或查看,没有账号?立即注册

x
设某银行有A、B两个业务窗口,且处理业务的速度不一样,其中A窗口处理速度是B窗口的2倍 —— 即当A窗口每处理完2个顾客时,B窗口处理完1个顾客。给定到达银行的顾客序列,请按业务完成的顺序输出顾客序列。假定不考虑顾客先后到达的时间间隔,并且当不同窗口同时处理完2个顾客时,A窗口顾客优先输出。

输入格式:
输入为一行正整数,其中第1个数字N(≤1000)为顾客总数,后面跟着N位顾客的编号。编号为奇数的顾客需要到A窗口办理业务,为偶数的顾客则去B窗口。数字间以空格分隔。

输出格式:
按业务处理完成的顺序输出顾客的编号。数字间以空格分隔,但最后一个编号后不能有多余的空格。

输入样例:
8 2 1 3 9 4 11 13 15
输出样例:
1 3 2 9 11 4 13 15

这题用C或者C++怎么做
最佳答案
2024-11-1 18:11:48
要解决这个问题,我们可以使用两个队列来模拟A和B窗口的处理过程。A窗口的处理速度是B窗口的两倍,因此我们需要在A窗口处理两个顾客后,B窗口才能处理一个顾客。以下是一个用C++实现的简单示例:
#include <iostream>
#include <queue>
#include <vector>

int main() {
    int N;
    std::cin >> N;
    std::queue<int> queueA, queueB;
    std::vector<int> result;

    for (int i = 0; i < N; ++i) {
        int customer;
        std::cin >> customer;
        if (customer % 2 == 1) {
            queueA.push(customer);
        } else {
            queueB.push(customer);
        }
    }

    while (!queueA.empty() || !queueB.empty()) {
        // A窗口处理两个顾客
        for (int i = 0; i < 2 && !queueA.empty(); ++i) {
            result.push_back(queueA.front());
            queueA.pop();
        }
        // B窗口处理一个顾客
        if (!queueB.empty()) {
            result.push_back(queueB.front());
            queueB.pop();
        }
    }

    for (size_t i = 0; i < result.size(); ++i) {
        if (i > 0) {
            std::cout << " ";
        }
        std::cout << result[i];
    }

    return 0;
}

这个程序首先将顾客分配到两个队列中,分别对应A和B窗口。然后按照A窗口处理两个顾客、B窗口处理一个顾客的顺序,将处理完的顾客编号存入结果向量中,最后输出结果。

以上回复来自 FishC AI 小助理,如未能正确解答您的问题,请继续追问。
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 2024-11-1 18:11:48 | 显示全部楼层    本楼为最佳答案   
要解决这个问题,我们可以使用两个队列来模拟A和B窗口的处理过程。A窗口的处理速度是B窗口的两倍,因此我们需要在A窗口处理两个顾客后,B窗口才能处理一个顾客。以下是一个用C++实现的简单示例:
#include <iostream>
#include <queue>
#include <vector>

int main() {
    int N;
    std::cin >> N;
    std::queue<int> queueA, queueB;
    std::vector<int> result;

    for (int i = 0; i < N; ++i) {
        int customer;
        std::cin >> customer;
        if (customer % 2 == 1) {
            queueA.push(customer);
        } else {
            queueB.push(customer);
        }
    }

    while (!queueA.empty() || !queueB.empty()) {
        // A窗口处理两个顾客
        for (int i = 0; i < 2 && !queueA.empty(); ++i) {
            result.push_back(queueA.front());
            queueA.pop();
        }
        // B窗口处理一个顾客
        if (!queueB.empty()) {
            result.push_back(queueB.front());
            queueB.pop();
        }
    }

    for (size_t i = 0; i < result.size(); ++i) {
        if (i > 0) {
            std::cout << " ";
        }
        std::cout << result[i];
    }

    return 0;
}

这个程序首先将顾客分配到两个队列中,分别对应A和B窗口。然后按照A窗口处理两个顾客、B窗口处理一个顾客的顺序,将处理完的顾客编号存入结果向量中,最后输出结果。

以上回复来自 FishC AI 小助理,如未能正确解答您的问题,请继续追问。
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1 | 粤公网安备 44051102000585号)

GMT+8, 2024-11-21 18:44

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表