鱼C论坛

 找回密码
 立即注册
查看: 92|回复: 3

[已解决]c++问题

[复制链接]
发表于 5 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能^_^

您需要 登录 才可以下载或查看,没有账号?立即注册

x
题目描述
输入一个大于0的大整数N,长度不超过100位,要求输出其除以13得到的商和余数。
输入
一个大于0的大整数,长度不超过100位。
输出
两行,分别为整数除法得到的商和余数。
样例输入
2132104848488485
样例输出
164008065268345
0

我的代码:
#include<bits/stdc++.h>
using namespace std;
string s;
int yu, i;
int a[102] = {}, b[102] = {};
int main(){
        //输入
        cin >> s;
        int la = s.size();
        int lb = la - 1;
       
        for (i=0; i<la; i++) a[i+1] = s[i] - '0';
        yu = a[1];
       
        //相除
        for(i=2; i<=la; i++){
            b[i] = (yu*10 + a[i]) / 13;
            yu = (yu*10 + a[i]) % 13;
        }
       
        while (b[lb] == 0 && lb > 1) lb--;
        //输出
        if (b[2] == 0) {
            for (i=3; i>=lb; i++) cout << b[i];
        } else {
            for (i=2; i>=lb; i++) cout << b[i];
        }
        cout << "\n" << yu;
        return 0;
}
最佳答案
5 天前
看起来您在编写C++代码时遇到了一些问题。让我帮助您修正代码并实现题目要求。以下是一个可以解决该问题的C++代码示例:
#include <iostream>
#include <string>
using namespace std;

int main() {
    string s;
    cin >> s;
    
    int remainder = 0;
    string quotient;
    
    for (char c : s) {
        int num = remainder * 10 + (c - '0');
        quotient += (num / 13) + '0';
        remainder = num % 13;
    }
    
    // 去掉商的前导零
    size_t pos = quotient.find_first_not_of('0');
    if (pos != string::npos) {
        quotient = quotient.substr(pos);
    } else {
        quotient = "0";
    }
    
    cout << quotient << endl;
    cout << remainder << endl;
    
    return 0;
}

这个代码的逻辑是逐位处理输入的大整数字符串,计算每一步的商和余数。最终输出商和余数。请注意,代码中去掉了商的前导零以确保输出格式正确。

以上回复来自 FishC AI 小助理,如未能正确解答您的问题,请继续追问。
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 5 天前 | 显示全部楼层    本楼为最佳答案   
看起来您在编写C++代码时遇到了一些问题。让我帮助您修正代码并实现题目要求。以下是一个可以解决该问题的C++代码示例:
#include <iostream>
#include <string>
using namespace std;

int main() {
    string s;
    cin >> s;
    
    int remainder = 0;
    string quotient;
    
    for (char c : s) {
        int num = remainder * 10 + (c - '0');
        quotient += (num / 13) + '0';
        remainder = num % 13;
    }
    
    // 去掉商的前导零
    size_t pos = quotient.find_first_not_of('0');
    if (pos != string::npos) {
        quotient = quotient.substr(pos);
    } else {
        quotient = "0";
    }
    
    cout << quotient << endl;
    cout << remainder << endl;
    
    return 0;
}

这个代码的逻辑是逐位处理输入的大整数字符串,计算每一步的商和余数。最终输出商和余数。请注意,代码中去掉了商的前导零以确保输出格式正确。

以上回复来自 FishC AI 小助理,如未能正确解答您的问题,请继续追问。
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

 楼主| 发表于 5 天前 | 显示全部楼层
FishC 发表于 2025-1-16 10:30
看起来您在编写C++代码时遇到了一些问题。让我帮助您修正代码并实现题目要求。以下是一个可以解决该问题的C ...

为什么我的代码输出的商是0?
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

发表于 5 天前 | 显示全部楼层
Orig 发表于 2025-01-16 10:32
FishC 发表于 2025-1-16 10:30
看起来您在编写C++代 ...


您提到的代码片段似乎不完整,并且有一些语法错误。以下是一些可能导致商为0的原因:

1. **循环条件错误**:`for (i=0; i=lb; i++)` 这个条件会导致循环不执行,因为`i=lb`是一个赋值操作,而不是比较操作。应该是`i < lb`。

2. **输出错误**:`cout = lb; i++) cout` 这部分代码不完整,可能是由于错误的复制粘贴导致的。

3. **初始化错误**:`int a = {}, b = {};` 这行代码的初始化方式不正确。

以下是一个完整的代码示例,解决了上述问题,并正确计算商和余数:
#include <iostream>
#include <string>
using namespace std;

int main() {
    string s;
    cin >> s;
    
    int remainder = 0;
    string quotient;
    
    for (char c : s) {
        int num = remainder * 10 + (c - '0');
        quotient += (num / 13) + '0';
        remainder = num % 13;
    }
    
    // 去掉商的前导零
    size_t pos = quotient.find_first_not_of('0');
    if (pos != string::npos) {
        quotient = quotient.substr(pos);
    } else {
        quotient = "0";
    }
    
    cout << quotient << endl;
    cout << remainder << endl;
    
    return 0;
}

请确保您在代码中正确处理了输入字符串,并且在计算商和余数时没有遗漏任何步骤。这样可以确保输出的商和余数是正确的。

以上回复来自 FishC AI 小助理,如未能正确解答您的问题,请继续追问。
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1 | 粤公网安备 44051102000585号)

GMT+8, 2025-1-21 18:48

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表