鱼C论坛

 找回密码
 立即注册
查看: 172|回复: 12

我安装了xlrd模块,但运行脚本的exe说缺少xlrd,怎么解决?

[复制链接]
发表于 2021-1-8 16:08:39 | 显示全部楼层 |阅读模式
5鱼币
我用Pyinstaller打包了我的一个py脚本成exe,解决了库的问题终于没有闪退了之后运行到一半突然来了一个ImportError: Missing optional dependency 'xlrd'. Install xlrd >= 1.0.0 for Excel support Use pip or conda to install xlrd.

然后我用pip list看了一下安装列表,确实也有xlrd啊,version还是2.0.1,为什么会报错?该怎么解决,求大佬解答,5鱼币

想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
发表于 2021-1-8 16:13:35 | 显示全部楼层
你还是再 pip install xlrd 一下试试,毕竟它报错信息就是这
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
 楼主| 发表于 2021-1-8 16:15:48 | 显示全部楼层
qq1151985918 发表于 2021-1-8 16:13
你还是再 pip install xlrd 一下试试,毕竟它报错信息就是这

Requirement already satisfied
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
发表于 2021-1-8 16:17:53 | 显示全部楼层
lzymm1 发表于 2021-1-8 16:15
Requirement already satisfied

那它提示满足要求不行你就再pyinstaller一下?
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
 楼主| 发表于 2021-1-8 16:19:03 | 显示全部楼层
qq1151985918 发表于 2021-1-8 16:17
那它提示满足要求不行你就再pyinstaller一下?

是不是必须要安装到什么指定的路径?
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
发表于 2021-1-8 16:20:24 | 显示全部楼层
lzymm1 发表于 2021-1-8 16:19
是不是必须要安装到什么指定的路径?
  1. pyinstaller [主文件] -p [其他文件1] -p [其他文件2] --hidden-import [自建模块1] --hidden-import [自建模块2]
复制代码
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
发表于 2021-1-8 16:21:11 | 显示全部楼层
本帖最后由 qq1151985918 于 2021-1-8 16:22 编辑
lzymm1 发表于 2021-1-8 16:19
是不是必须要安装到什么指定的路径?


https://blog.csdn.net/CholenMine/article/details/80964272

https://blog.csdn.net/kaituojimo/article/details/79186557

你根据这两个看看你问题在哪
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
 楼主| 发表于 2021-1-8 16:32:26 | 显示全部楼层
qq1151985918 发表于 2021-1-8 16:21
https://blog.csdn.net/CholenMine/article/details/80964272

https://blog.csdn.net/kaituojimo/ar ...

第二个,但是我没有Pycharm,就用cmd或者idle能搞定吗?
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
发表于 2021-1-8 16:39:14 | 显示全部楼层
查看模块路径查看方法  os为例

  1. import os
  2. print(os.__file__)
复制代码
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
 楼主| 发表于 2021-1-8 16:46:36 | 显示全部楼层
qq1151985918 发表于 2021-1-8 16:39
查看模块路径查看方法  os为例

找到了,然后呢?
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
发表于 2021-1-8 16:48:37 | 显示全部楼层
lzymm1 发表于 2021-1-8 16:46
找到了,然后呢?

然后你不是跟第二个网址的情况一样么,照着作不就行了
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
 楼主| 发表于 2021-1-8 17:30:13 | 显示全部楼层
qq1151985918 发表于 2021-1-8 16:48
然后你不是跟第二个网址的情况一样么,照着作不就行了

ValueError:Your version of xlrd is 2.0.1. In xlrd>=2.0,onlythe xls format is spported.install openpyxl instead
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
发表于 2021-1-8 17:54:02 From FishC Mobile | 显示全部楼层
lzymm1 发表于 2021-1-8 17:30
ValueError:Your version of xlrd is 2.0.1. In xlrd>=2.0,onlythe xls format is spported.install open ...

报错提示xlrd 版本大于等于2.0,只支持xls格式文档,安装openpyxl代替
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1

GMT+8, 2021-1-18 00:17

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表