鱼C论坛

 找回密码
 立即注册
查看: 388|回复: 7

咱们论坛上的一位鱼油写的坦克大战,我运行的是提示错误大家帮我看看

[复制链接]
最佳答案
0 
发表于 2019-1-31 20:21:21 | 显示全部楼层 |阅读模式
100鱼币
本帖最后由 lizhiyong_11 于 2019-2-1 11:37 编辑

https://fishc.com.cn/thread-81941-1-1.html
这是鱼油帖子地址
下面是错误信息
  1. Traceback (most recent call last):
  2.   File "C:\Users\WIN8.1\Desktop\tank\tank\tank.py", line 8, in <module>
  3.     ct = win32api.GetConsoleTitle()
  4. pywintypes.error: (6, 'GetConsoleTitle', '句柄无效。')
复制代码

想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
最佳答案
0 
 楼主| 发表于 2019-1-31 20:43:32 | 显示全部楼层
我用python3.4打开的时候提示我缺少win32pai,我在python3.4上并没有安装成功pywin32,所以我下载了最新版本3.7,但是却提示句柄错误
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
最佳答案
1440 
发表于 2019-2-1 09:11:23 | 显示全部楼层
你得问作者当时编写的代码用的pygame版本是多少
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
最佳答案
3 
发表于 2019-2-1 09:23:44 | 显示全部楼层
我用的是Pygame1.9.4,可以运行
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
最佳答案
0 
 楼主| 发表于 2019-2-1 09:33:19 | 显示全部楼层
塔利班 发表于 2019-2-1 09:11
你得问作者当时编写的代码用的pygame版本是多少

如果现在想让他在我这个版本下运行,有办法吗?
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
最佳答案
0 
 楼主| 发表于 2019-2-1 09:33:51 | 显示全部楼层
qiuyouzhi 发表于 2019-2-1 09:23
我用的是Pygame1.9.4,可以运行

好像是我版本的问题,但是我想用当前版本让他运行起来有办法吗?
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
最佳答案
1440 
发表于 2019-2-1 09:39:34 | 显示全部楼层
lizhiyong_11 发表于 2019-2-1 09:33
如果现在想让他在我这个版本下运行,有办法吗?

你得找到api的差别,具体就是看代码,你得学过pygame才能把代码改出来,所以不建议你先玩,先把小甲鱼打飞机课程看完
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
最佳答案
3 
发表于 2019-2-6 16:31:34 | 显示全部楼层
你试试下个pywin32,用你Python的版本
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

小甲鱼强烈推荐上一条 /1 下一条

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号

GMT+8, 2019-2-24 03:03

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表