鱼C论坛

 找回密码
 立即注册
查看: 1068|回复: 4

[已解决]字符串分类统计

[复制链接]
发表于 2020-2-28 17:13:31 | 显示全部楼层 |阅读模式
10鱼币
题目
题目描述

输入一行字符,分别统计出其中英文字母、数字、空格和其他字符的个数。
输入

一行字符
输出

统计值
样例输入

aklsjflj123 sadf918u324 asdf91u32oasdf/.';123

样例输出

23 16 2 4

提示

此类题目为编程入门基本语法巩固练习,为单组测试数据

我的 代码 运行后的结果
22 17 2 4
#include <stdio.h>
#include <stdlib.h>
#include <ctype.h>

struct a{
    struct a *previous;
    char b;
    struct a *next;
};
 
int main(){ 

    char temp=getchar();
    struct a *c=malloc(sizeof(struct a));
    if(c!=NULL)c->previous=NULL;
    struct a *swap=NULL;

    do{ 
        c->next=malloc(sizeof(struct a));
        if(c->next!=NULL){ 
            swap=c;
            c=c->next;
            c->previous=swap;
            c->b=temp; 
        }else{
            printf("malloc failed!\n");
            return 1;
        }
        temp=getchar();
       
        if(temp!=10){
           c->b=temp; 
        }else{
            break;
        }

    }while(1);

        c->next=NULL;
    int letter=0,space=0,digit=0,specialchar=0;

    do{
            if(isalpha(c->b)){
                letter++;
            }else if(isspace(c->b)){
                space++;
            }else if(isdigit(c->b)){
                digit++;
            }else{
                specialchar++;
            }
            
            c=c->previous;
            free(c->next);
            c->next=NULL;
 
    }while(c->previous!=NULL);
            printf("%d %d %d %d\n",letter,digit,space,specialchar);

    return 0;
} 

谢谢
最佳答案
2020-2-28 17:13:32
#include <stdio.h>
main(void)
{
        char x , s[256]                                                   ;
        int b , c , d , m , o                                             ;
        for(b = 0 , c = 0 , d = 0 , m = 0 , o = 0 ; (x = getchar()) != '\n'&& m < 255 ; s[m ++] = x , s[m] = '\0') {
                if((x >= 'a' && x <= 'z') || (x >= 'A' && x <= 'Z')) c ++ ;
                else if(x >= '0' && x <= '9') d ++                        ;
                else if(x == ' ') b ++                                    ;
                else o ++                                                 ;
        }
        printf("%d %d %d %d\n" , c , d , b , o)
}
        编译运行实况:
C:\Bin>g++ -o x x.c

C:\Bin>x
aklsjflj123 sadf918u324 asdf91u32oasdf/.';123
23 16 2 4

C:\Bin>

最佳答案

查看完整内容

编译运行实况:
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 2020-2-28 17:13:32 | 显示全部楼层    本楼为最佳答案   
#include <stdio.h>
main(void)
{
        char x , s[256]                                                   ;
        int b , c , d , m , o                                             ;
        for(b = 0 , c = 0 , d = 0 , m = 0 , o = 0 ; (x = getchar()) != '\n'&& m < 255 ; s[m ++] = x , s[m] = '\0') {
                if((x >= 'a' && x <= 'z') || (x >= 'A' && x <= 'Z')) c ++ ;
                else if(x >= '0' && x <= '9') d ++                        ;
                else if(x == ' ') b ++                                    ;
                else o ++                                                 ;
        }
        printf("%d %d %d %d\n" , c , d , b , o)
}
        编译运行实况:
C:\Bin>g++ -o x x.c

C:\Bin>x
aklsjflj123 sadf918u324 asdf91u32oasdf/.';123
23 16 2 4

C:\Bin>
想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 2020-2-28 17:51:54 | 显示全部楼层
为啥要弄这么复杂,还用链表?
#include <stdio.h>
#include <ctype.h>

int main()
{
    printf("Please input one line:\n");
    char ch = getchar();
    int letters = 0;
    int digits = 0;
    int spaces = 0;
    int others = 0;
    while (ch != '\n')
    {
        if (isalpha(ch))
        {
            letters++;
        }
        else if (isspace(ch))
        {
            spaces++;
        }
        else if (isdigit(ch))
        {
            digits++;
        }
        else
        {
            others++;
        }
        ch = getchar();
    }
    printf("letters: %d, digits: %d, spaces: %d, others: %d", letters, digits, spaces, others);

    return 0;
}

评分

参与人数 1荣誉 +5 鱼币 +5 贡献 +3 收起 理由
rt3 + 5 + 5 + 3

查看全部评分

想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 2020-2-28 18:43:50 | 显示全部楼层
#include<stdio.h>


void fun1(char* s ){
        int a,b,c,d;
        a=b=c=d=0;

    for(int i=0;s[i]!='\0';i++)
    {
        if((s[i]>='a'&&s[i]<='z')||(s[i]>='A'&&s[i]<='Z'))a++;
        else if(s[i]>='0'&&s[i]<='9') b++;
        else if(s[i]==' ')c++;
        else d++;
    }

          printf("%d %d %d %d",a,b,c,d);


}


int main()
{
            char s[100];
        scanf("%[^\n]s",&s);
        fun1(s);
    return 0;
}

评分

参与人数 1荣誉 +5 鱼币 +5 贡献 +3 收起 理由
rt3 + 5 + 5 + 3 鱼C有你更精彩^_^

查看全部评分

想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

发表于 2020-2-28 19:09:45 | 显示全部楼层
#include<stdio.h>
#include<stdlib.h>

#define MAX_VOLUMN 255

int main()
{        
        char buffer[MAX_VOLUMN] = "aklsjflj123 sadf918u324 asdf91u32oasdf/.';123";
        char *p = buffer;
        int ret[4] = {0};
        while(*p != '\0')
        {
                if((*p >= 65 && *p <=90)||(*p >=97 && *p <=122))        
                        ret[0] += 1;
                else if (*p >= 48 && *p <= 57)
                        ret[1] += 1;
                else if(*p == 32)
                        ret[2] += 1;
                else
                        ret[3] += 1;
                p++;
        }
        int i;
        for(i = 0; i < 4; i++)
        {
                printf("%d ", ret[i]);
        }
        printf("\n");
        return 0;
}

评分

参与人数 1荣誉 +1 鱼币 +3 贡献 +1 收起 理由
rt3 + 1 + 3 + 1

查看全部评分

想知道小甲鱼最近在做啥?请访问 -> ilovefishc.com
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备18085999号-1 | 粤公网安备 44051102000585号)

GMT+8, 2025-1-15 22:59

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表