为什么不能正常运行?无法输入第二个数字??
Problem Description
对于给定的一个字符串,统计其中数字字符出现的次数。
Input
输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。
Output
对于每个测试实例,输出该串中数值的个数,每个输出占一行。
Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf
Sample Output
6
9
我的代码如下#include<stdio.h>
#include<string.h>
int main()
{ char b[101];
int n=0,f,j;
int a,e,i,o,u;
while(scanf("%d",&n)!=EOF);
{
getchar();
for(int f=0;f<n;f++)
{ gets(b);
a=0, e=0, i=0, o=0, u=0;
for(int j=0;j<strlen(b);j++)
{
if(b[j]=='a'||b[j]=='A')
a++;
else if(b[j]=='e'||b[j]=='E')
e++;
else if(b[j]=='i'||b[j]=='I')
i++;
else if(b[j]=='o'||b[j]=='O')
o++;
else if(b[j]=='u'||b[j]=='U')
u++;
}
}
if(f==n-1)
{printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n",a,e,i,o,u);}
else
{printf("a:%d\ne:%d\ni:%d\no:%d\nu:%d\n\n",a,e,i,o,u);}
}
return 0;
}
其他的 这类问题
你这么写能通过吗?我感觉这类问题不是这个意思
接收一行输入,计算,输出
然后再接收一行输入,计算,输出
然后再接收一行输入,计算,输出
。。。
上一个代码的模板,稍微改了改 #include <stdio.h>
#include <memory.h>
#include <ctype.h>
int main(void) {
size_t n; scanf("%lu\n", &n);
char strings[n][101];
for(size_t i = 0; i < n; ++i) fgets(strings[i], 101, stdin);
size_t counts[n]; memset(counts, 0, sizeof(counts));
for(size_t i = 0; i < n; ++i) {
for(size_t j = 0; strings[i][j]; ++j) {
if(isdigit(strings[i][j])) ++counts[i];
}
}
for(size_t i = 0; i < n; ++i) {
printf("%lu\n", counts[i]);
}
return 0;
}
|