|
马上注册,结交更多好友,享用更多功能^_^
您需要 登录 才可以下载或查看,没有账号?立即注册
x
6-10 使用函数输出水仙花数
分数 10
作者 张高燕
单位 浙大城市学院
水仙花数是指一个N位正整数(N≥3),它的每个位上的数字的N次幂之和等于它本身。例如:153=1
3
+5
3
+3
3
。 本题要求编写两个函数,一个判断给定整数是否水仙花数,另一个按从小到大的顺序打印出给定区间(m,n)内所有的水仙花数。
函数接口定义:
int narcissistic( int number );
void PrintN( int m, int n );
函数narcissistic判断number是否为水仙花数,是则返回1,否则返回0。
函数PrintN则打印开区间(m, n)内所有的水仙花数,每个数字占一行。题目保证100≤m≤n≤10000。
裁判测试程序样例:
#include <stdio.h>
int narcissistic( int number );
void PrintN( int m, int n );
int main()
{
int m, n;
scanf("%d %d", &m, &n);
if ( narcissistic(m) ) printf("%d is a narcissistic number\n", m);
PrintN(m, n);
if ( narcissistic(n) ) printf("%d is a narcissistic number\n", n);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
153 400
输出样例:
153 is a narcissistic number
370
371
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
C (gcc)
1
2
3
4
int narcissistic(int number)
{
}
这题函数怎么写
题目要求实现两个函数,一个函数判断给定整数是否为水仙花数,另一个函数按照从小到大的顺序打印出给定区间内所有的水仙花数。
首先,我们需要明确什么是水仙花数。水仙花数是指一个N位正整数(N≥3),它的每个位上的数字的N次幂之和等于它本身。例如:153=1^3 + 5^3 + 3^3。
接下来,我们来实现第一个函数 narcissistic ,判断给定整数是否为水仙花数。函数接收一个整数参数 number ,如果 number 是水仙花数,则返回1,否则返回0。
- int narcissistic(int number)
- {
- int temp = number;
- int sum = 0;
- int digit;
- int n = 0;
-
- // 计算number的位数
- while(temp > 0) {
- temp /= 10;
- n++;
- }
-
- temp = number;
-
- // 计算每个位上的数字的N次幂之和
- while(temp > 0) {
- digit = temp % 10;
- sum += pow(digit, n);
- temp /= 10;
- }
-
- // 判断是否为水仙花数
- if(sum == number) {
- return 1;
- } else {
- return 0;
- }
- }
复制代码
接下来,我们实现第二个函数 PrintN ,按照从小到大的顺序打印出给定区间内所有的水仙花数。函数接收两个整数参数 m 和 n ,表示区间范围。
- void PrintN(int m, int n)
- {
- int i;
-
- // 遍历区间内的每个数字
- for(i = m + 1; i < n; i++) {
- // 判断是否为水仙花数
- if(narcissistic(i)) {
- printf("%d\n", i);
- }
- }
- }
复制代码
以上是题目要求的两个函数的实现。在 main 函数中,我们可以按照题目要求调用这两个函数。
- int main()
- {
- int m, n;
- scanf("%d %d", &m, &n);
- if(narcissistic(m)) {
- printf("%d is a narcissistic number\n", m);
- }
- PrintN(m, n);
- if(narcissistic(n)) {
- printf("%d is a narcissistic number\n", n);
- }
- return 0;
- }
复制代码
这样就完成了题目要求的两个函数的实现。
|
|